Cisco 400-101 exam is a very important regarding Exambible examination. Moscow and rome few decades, laptop or computer scientific research education made the majority of particular attention and folks globally. All of our 400-101 guidelines make sure people go ones official certifications 400-101 exam credit score ones try, like a documented geologist community gadgets. You are able to get your certificates check-ups, finding your way through ones 400-101 exam preparing guideline that assists people with not exclusively from the excellent of this 400-101 exam, however , for you to convince people that the aim of 400-101 exam.

2017 Mar 400-101 question

Q1. Refer to the exhibit. 

Which BGP feature allows R1 to send R2 a list of prefixes that R2 is prevented from advertising to R1? 

A. route refresh 

B. Prefix-Based Outbound Route Filtering 

C. distribute lists 

D. prefix lists 

Answer:


Q2. Which statement describes the difference between a stub area and a totally stub area? 

A. The ABR advertises a default route to a totally stub area and not to a stub area. 

B. Stub areas do not allow LSA types 4 and 5, while totally stub areas do not allow LSA types 3, 4, and 5. 

C. Totally stub areas allow limited external routes in the area via a special type 7 LSA, while stub areas do not. 

D. Stub areas do not allow external LSAs, ASBR summary LSAs, or summary LSAs with the exception of a default route originated by the ABR via a summary LSA. 

Answer:

Explanation: 

. Standard areas can contain LSAs of type 1, 2, 3, 4, and 5, and may contain an ASBR. The backbone is considered a standard area. 

. Stub areas can contain type 1, 2, and 3 LSAs. A default route is substituted for external routes. 

. Totally stubby areas can only contain type 1 and 2 LSAs, and a single type 3 LSA. The type 3 LSA describes a default route, substituted for all external and inter-area routes. 

. Not-so-stubby areas implement stub or totally stubby functionality yet contain an ASBR. Type 7 LSAs generated by the ASBR are converted to type 5 by ABRs to be flooded to the rest of the OSPF domain. 

Reference: http://packetlife.net/blog/2008/jun/24/ospf-area-types/ 


Q3. Which two statements about the BGP community attribute are true? (Choose two.) 

A. Routers send the community attribute to all BGP neighbors automatically. 

B. A router can change a received community attribute before advertising it to peers. 

C. It is a well-known, discretionary BGP attribute. 

D. It is an optional transitive BGP attribute. 

E. A prefix can support only one community attribute. 

Answer: B,D 

Explanation: 

A community is a group of prefixes that share some common property and can be configured with the BGP community attribute. The BGP Community attribute is an optional transitive attribute of variable length. The attribute consists of a set of four octet values that specify a community. The community attribute values are encoded with an Autonomous System (AS) number in the first two octets, with the remaining two octets defined by the AS. A prefix can have more than one community attribute. A BGP speaker that sees multiple community attributes in a prefix can act based on one, some or all the attributes. A router has the option to add or modify a community attribute before the router passes the attribute on to other peers. 

Reference: 

http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/28784-bgp-community.html 


Q4. Which three statements about implementing an application layer gateway in a network are true? (Choose three.) 

A. It allows client applications to use dynamic ports to communicate with a server regardless of whether NAT is being used. 

B. It maintains granular security over application-specific data. 

C. It allows synchronization between multiple streams of data between two hosts. 

D. Application layer gateway is used only in VoIP/SIP deployments. 

E. Client applications require additional configuration to use an application layer gateway. 

F. An application layer gateway inspects only the first 64 bytes of a packet before forwarding it through the network. 

Answer: A,B,C 

Explanation: 

An ALG may offer the following functions: 

. allowing client applications to use dynamic ephemeral TCP/ UDP ports to communicate with the known ports used by the server applications, even though a firewall configuration may allow only a limited number of known ports. In the absence of an ALG, either the ports would get blocked or the network administrator would need to explicitly open up a large number of ports in the firewall — rendering the network vulnerable to attacks on those ports. 

. converting the network layer address information found inside an application payload between the addresses acceptable by the hosts on either side of the firewall/NAT. This aspect introduces the term 'gateway' for an ALG. 

. recognizing application-specific commands and offering granular security controls over them 

. synchronizing between multiple streams/sessions of data between two hosts exchanging data. For example, an FTP application may use separate connections for passing control commands and for exchanging data between the client and a remote server. During large file transfers, the control connection may remain idle. An ALG can prevent the control connection getting timed out by network devices before the lengthy file transfer completes. 

Reference: http://en.wikipedia.org/wiki/Application-level_gateway 


Q5. How does having an EIGRP feasible successor speed up convergence? 

A. EIGRP sends queries only if there is a feasible successor, which decreases the number of routers that are involved in convergence. 

B. EIGRP sends queries only if there is not a feasible successor, which causes less control traffic to compete with data. 

C. EIGRP immediately installs the loop-free alternative path in the RIB. 

D. EIGRP preinstalls the feasible successor in the RIB in all cases, which causes traffic to switch more quickly. 

Answer:

Explanation: 

Feasible Successor 

. A next-hop router that serves as backup to the current successor. 

. The condition is that the said router’s AD (or RD) is less than the FD of the current successor route. 

. Once the feasible successor is selected, they are placed in the topology table. If a change in topology occurs which requires a new route, DUAL looks for the feasible successor and uses it as new route immediately, resulting in fast convergence. 

Reference: http://routemyworld.com/2008/07/page/2/ 


Avant-garde 400-101 exam prep:

Q6. DRAG DROP 

Drag and drop the IS-IS component on the left to the function that it performs on the right. 

Answer: 


Q7. Refer to the exhibit. 

Why is the prefix 1.1.1.1/32 not present in the routing table of R1? 

A. There is a duplicate router ID. 

B. There is a subnet mask mismatch on Ethernet0/0. 

C. The router LSA has an invalid checksum. 

D. There is an OSPF network type mismatch that causes the advertising router to be unreachable. 

Answer:

Explanation: 

A common problem when using Open Shortest Path First (OSPF) is routes in the database don't appear in the routing table. In most cases OSPF finds a discrepancy in the database so it doesn't install the route in the routing table. Often, you can see the Adv Router is not-reachable message (which means that the router advertising the LSA is not reachable through OSPF) on top of the link-state advertisement (LSA) in the database when this problem occurs. Here is an example: 

Adv Router is not-reachable 

LS agE. 418 

Options: (No TOS-capability, DC) 

LS TypE. Router 

Links Link State ID. 172.16.32.2 

Advertising Router: 172.16.32.2 

LS Seq Number: 80000002 

Checksum: 0xFA63 

Length: 60 

Number of Links: 3 

There are several reasons for this problem, most of which deal with mis-configuration or a broken topology. When the configuration is corrected the OSPF database discrepancy goes away and the routes appear in the routing table. 

Reason 1: Network Type Mismatch 

Let's use the following network diagram as an example: 

R4-4K 

R1-7010 

interface Loopback0 

ip address 172.16.33.1 255.255.255.255 

interface Serial2 

ip address 172.16.32.1 255.255.255.0 

ip ospf network broadcast 

router ospf 20 

network 172.16.0.0 0.0.255.255 area 0 

interface Loopback0 

ip address 172.16.30.1 255.255.255.255 

interface Serial1/0 

ip address 172.16.32.2 255.255.255.0 

clockrate 64000 

router ospf 20 

network 172.16.0.0 0.0.255.255 area 0 

R4-4K(4)# show ip ospf interface serial 2 

Serial2 is up, line protocol is up 

Internet Address 172.16.32.1/24, Area 0 

Process ID 20, Router ID 172.16.33.1, Network Type BROADCAST, Cost: 64 

Transmit Delay is 1 sec, State DR, Priority 1 

Designated Router (ID) 172.16.33.1, Interface address 172.16.32.1 

Backup Designated router (ID) 172.16.32.2, Interface address 172.16.32.2 

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 

Hello due in 00:00:08 

Neighbor Count is 1, Adjacent neighbor count is 1 

Adjacent with neighbor 172.16.32.2 (Backup Designated Router) 

Suppress hello for 0 neighbor(s) 

R1-7010(5)# show ip ospf interface serial 1/0 

Serial1/0 is up, line protocol is up 

Internet Address 172.16.32.2/24, Area 0 

Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64 

Transmit Delay is 1 sec, State POINT_TO_POINT, 

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 

Hello due in 00:00:02 

Neighbor Count is 1, Adjacent neighbor count is 1 

Adjacent with neighbor 172.16.33.1 

Suppress hello for 0 neighbor(s) 

As you can see above, Router R4-4K is configured for broadcast, and Router R1-7010 is configured for point-to-point. This kind of network type mismatch makes the advertising router unreachable. 

R4-4K(4)# show ip ospf database router 172.16.32.2 

Adv Router is not-reachable 

LS agE. 418 

Options: (No TOS-capability, DC) 

LS TypE. Router Links 

Link State ID. 172.16.32.2 

Advertising Router: 172.16.32.2 

LS Seq Number: 80000002 

Checksum: 0xFA63 

Length: 60 

Number of Links: 3 

Link connected to: another Router (point-to-point) 

(Link ID) Neighboring Router ID. 172.16.33.1 

(Link Data) Router Interface address: 172.16.32.2 

Number of TOS metrics: 0 

TOS 0 Metrics: 64 

Link connected to: a Stub Network 

(Link ID) Network/subnet number: 172.16.32.0 

(Link Data) Network Mask: 255.255.255.0 

Number of TOS metrics: 0 

TOS 0 Metrics: 64 

R1-7010(5)# show ip ospf database router 172.16.33.1 

Adv Router is not-reachable 

LS agE. 357 

Options: (No TOS-capability, DC) 

LS TypE. Router Links 

Link State ID. 172.16.33.1 

Advertising Router: 172.16.33.1 

LS Seq Number: 8000000A 

Checksum: 0xD4AA 

Length: 48 

Number of Links: 2 

Link connected to: a Transit Network 

(Link ID) Designated Router address: 172.16.32.1 

(Link Data) Router Interface address: 172.16.32.1 

Number of TOS metrics: 0 

TOS 0 Metrics: 64 

You can see that for subnet 172.16.32.0/24, Router R1-7010 is generating a point-to-point link and Router R4-4K is generating a transit link. This creates a discrepancy in the link-state database, which means no routes are installed in the routing table. 

R1-7010(5)# show ip route 

172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks 

C 172.16.32.0/24 is directly connected, Serial1/0 

C 172.16.30.1/32 is directly connected, Loopback0 

Solution 

To solve this problem, configure both routers for the same network type. You can either change the network type of Router R1-7010 to broadcast, or change Router R4-4K's serial interface to point-to-point. 

Reference: http://www.cisco.com/c/en/us/support/docs/ip/open-shortest-path-first-ospf/7112-26.html 


Q8. An IP SLA fails to generate statistics. How can you fix the problem? 

A. Add the verify-data command to the router configuration. 

B. Reload the router configuration. 

C. Remove the ip sla schedule statement from the router configuration and re-enter it. 

D. Add the debug ip sla error command to the router configuration. 

E. Add the debug ip sla trace command to the router configuration. 

Answer:


Q9. DRAG DROP 

Drag and drop the IPv6 prefix on the left to the correct address type on the right. 

Answer: 


Q10. Which two statements about ERSPAN are true? (Choose two.) 

A. It supports jumbo frames of up to 9202 bytes. 

B. It adds a 50-byte header to copied Layer 2 Ethernet frames. 

C. It supports packet fragmentation and reassembles the packets. 

D. It adds a 4-byte header to copied Layer 2 Ethernet frames. 

E. Source sessions on an individual switch can use different origin IP addresses. 

Answer: A,B